Issues with Support Tickets

Incident Report for Netilion

Resolved

The incident has been resolved
Posted May 07, 2026 - 08:22 CEST

Identified

We identified an issue with our Support Ticket system. It is currently not possible to create new support tickets or access existing tickets
We apologize for the inconvenience.
Posted May 06, 2026 - 16:46 CEST
This incident affected: Platform Services (Support Backend).