Partial outage Netilion API
Incident Report for Netilion
Postmortem

Description of Error

In the period between 24 and 26 of November 2023, some measurement data of specific devices (Micropilot FWR30, Fermentation Monitor QWX43) could not be processed. Other instruments were not affected. Unfortunately, part of this measurement data could not be retrieved after resolving the issue. The issue has been resolved, all data after 26 of November is available and up to date.

Root Cause

An unexpected high amount of regular activities on the Netilion platform led to some measurement data of specific devices not being processed and saved in our databases.

Solution

As an immediate action, the capacity of the affected internal components was substantially increased. In order to avoid an excessive amount of activities on the Netilion platform, new mechanisms were introduced that balance the load. In addition, the monitoring of the Netilion platform as well as the incident management process will be further improved to generally ensure a faster reaction time. We apologize for the inconvenience this may have caused. If you have any further questions, do not hesitate to contact your Endress+Hauser representative.

Posted Dec 12, 2023 - 09:34 CET

Resolved
The Netilion API had a partial outage.
Writing of data and measurement values was impacted.

As of now the problem is solved, while we continue to closely monitor all afffected systems.
Further updates will follow.
Posted Nov 24, 2023 - 21:00 CET