The issue affecting FUS has been resolved. All systems are now operating normally. We apologize for the disruption and appreciate your patience while we worked to restore service.
Posted May 28, 2026 - 15:04 CEST
Monitoring
Issue has been fixed. Our team is currently monitoring the system to ensure stability and confirm that the service is operating as expected.
Posted May 28, 2026 - 14:52 CEST
Identified
We’re continuing to investigate and address the issue affecting FUS. Our team is actively working to restore normal service. We appreciate your patience and will share more details as soon as they become available. At the moment all the Netilion users may still be affected. Next update in 60 minutes.
Posted May 28, 2026 - 13:32 CEST
Investigating
A partial service disruption has been identified in Firmware Update Scheduler. Our team is investigating and working on remediation. We apologize for any inconvenience. Netilion users may be affected. Next update in 30 minutes.
Posted May 28, 2026 - 12:59 CEST
This incident affected: Firmware Update Scheduler.